use strict;
my $str = 'lleonardo
jjjjjoaoooooo';
my $regex = qr/(.)(?=\1)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";