$re = '/(.)(?=\1)/m';
$str = 'lleonardo
jjjjjoaoooooo';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;