$re = '/(?<device>[^\(]+)\(\d+\)\sis\s(?<status>\w+)/';
$str = '\'aaaa bbbb cccc dddd\' (1234) is running.
\'akdg ytdf tyui tyhj\' (1245) is running.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);