re = /(?<device>[^\(]+)\(\d+\)\sis\s(?<status>\w+)/
str = '\'aaaa bbbb cccc dddd\' (1234) is running.
\'akdg ytdf tyui tyhj\' (1245) is running.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end