import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(function)?\\s*doFilter\\s*(:|=)?\\s*(function)?\\s*\\(";
final String string = "doFilter : function(){\n"
+ " var filters = $$('#'+this.containerId+' .filter input', '#'+this.containerId+' .filter select');\n"
+ " var elements = [];\n"
+ " for(var i in filters){\n"
+ " if(filters[i].value && filters[i].value.length) elements.push(filters[i]);\n"
+ " }\n"
+ " if (!this.doFilterCallback || (this.doFilterCallback && this.doFilterCallback())) {\n"
+ " this.reload(this.addVarToUrl(this.filterVar, encode_base64(Form.serializeElements(elements))));\n"
+ " }\n"
+ " },\n"
+ "doFilter = function(){\n"
+ " this.reload(this.addVarToUrl(this.filterVar, ''));\n"
+ "},\n"
+ "function doFilter(grid, event){\n"
+ " var element = Event.findElement(event, 'tr');\n"
+ " if(['a', 'input', 'select', 'option'].indexOf(Event.element(event).tagName.toLowerCase())!=-1) {\n"
+ " return;\n"
+ " }\n\n"
+ " if(element.title){\n"
+ " setLocation(element.title);\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}