# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(function)?\s*doFilter\s*(:|=)?\s*(function)?\s*\("
test_str = ("doFilter : function(){\n"
" var filters = $$('#'+this.containerId+' .filter input', '#'+this.containerId+' .filter select');\n"
" var elements = [];\n"
" for(var i in filters){\n"
" if(filters[i].value && filters[i].value.length) elements.push(filters[i]);\n"
" }\n"
" if (!this.doFilterCallback || (this.doFilterCallback && this.doFilterCallback())) {\n"
" this.reload(this.addVarToUrl(this.filterVar, encode_base64(Form.serializeElements(elements))));\n"
" }\n"
" },\n"
"doFilter = function(){\n"
" this.reload(this.addVarToUrl(this.filterVar, ''));\n"
"},\n"
"function doFilter(grid, event){\n"
" var element = Event.findElement(event, 'tr');\n"
" if(['a', 'input', 'select', 'option'].indexOf(Event.element(event).tagName.toLowerCase())!=-1) {\n"
" return;\n"
" }\n\n"
" if(element.title){\n"
" setLocation(element.title);\n"
" }\n"
"}")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.