const regex = /(?!^)(?=(\d{3})+$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!^)(?=(\\d{3})+$)', 'g')
const str = `2141241242412421455`;
const subst = `,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);