$re = '/(?!^)(?=(\d{3})+$)/';
$str = '2141241242412421455';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;