import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?=[a-zA-Z]*\\d)(?=\\d*[a-zA-Z])[a-zA-Z\\d]{6}\\b";
final String string = "Bus Express Wash at bay no 083457 - ABCDEF Truckno AB96CD & Truck no 12367S & 12368S";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}