re = /\b(?=[a-zA-Z]*\d)(?=\d*[a-zA-Z])[a-zA-Z\d]{6}\b/m
str = 'Bus Express Wash at bay no 083457 - ABCDEF Truckno AB96CD & Truck no 12367S & 12368S'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end