#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "dip=\"([^\"]*)\"([ ]dp=\"[^\"]*\")(?(?![ ]nat-dip="\1")([ ]nat-dip=\"([^\"]*)\")|[ ]nat-dip=\"([^\"]*)\")"
Local $sString = "sip="100.107.0.5" sp="123" dip="100.107.193.1" dp="123" nat-dip="84.2.44.19"" & @CRLF & _
"sip="100.101.199.1" sp="37690" dip="100.107.0.4" dp="80" nat-dip="100.107.0.4""
Local $sSubst = "dip="\4\5"\2\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)