using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(.+)?\]\(((https?:\/\/)?[A-Za-z0-9\:\/\.\- ]+)(\""(.+)\"")?\)";
string input = @"[test](http://google.com ""hello"")
[test](https://google.com ""hello"")
[test](google.com)
[](google.com)
[test](google.com ""hello"")
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}