// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\[(.+)?\]\(((https?:\/\/)?[A-Za-z0-9\:\/\.\- ]+)(\"(.+)\")?\)"#).unwrap();
let string = "[test](http://google.com \"hello\")
[test](https://google.com \"hello\")
[test](google.com)
[](google.com)
[test](google.com \"hello\")
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}