# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*time\s+)(\d{2}:\d{2}\s[ap]m)(.*)"
test_str = "there is some text and maybe some number or symbols time 12:32 am and there is some text"
subst = "${1}10:10 pm$3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.