const regex = /<(\w+)(\s[^>]*)?>\s*([^\s<].*?)(<\/\1>)/sg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(\\w+)(\\s[^>]*)?>\\s*([^\\s<].*?)(<\\\/\\1>)', 'sg')
const str = `<div class="ct_acc_cadre">
<h2>TEST</h2>
<ul> ok ça devrait
le faire
</ul>
<p> i'm <span> fuck up </span> gg</p>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}