$re = '/<(\w+)(\s[^>]*)?>\s*([^\s<].*?)(<\/\1>)/s';
$str = '<div class="ct_acc_cadre">
<h2>TEST</h2>
<ul> ok ça devrait
le faire
</ul>
<p> i\'m <span> fuck up </span> gg</p>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);