$re = '/^(?:(?:(?!xz).)*xz){2}(?:(?!xz).)*$/m';
$str = 'zzzxzdddxz
dddxzddddxzrrrxz
ssdffxzdddddd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);