re = /^(?:(?:(?!xz).)*xz){2}(?:(?!xz).)*$/m
str = 'zzzxzdddxz
dddxzddddxzrrrxz
ssdffxzdddddd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end