using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*(?=the)";
string input = @"this is completely customizable through the dashboard. This is a separate area from the main c";
RegexOptions options = RegexOptions.CultureInvariant | RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}