#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?!501|504)[0-9]*)$"
Local $sString = "500" & @CRLF & _
"501" & @CRLF & _
"502" & @CRLF & _
"aaa" & @CRLF & _
"503" & @CRLF & _
"504" & @CRLF & _
"505" & @CRLF & _
"bbb" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")