import re
regex = re.compile(r"^(\d{4}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2})(Z|[\+-]\d{2}:?\d{2})?$", flags=re.MULTILINE)
test_str = ("Should match ISO 8601 datetime for Forecast.io API:\n"
"[YYYY]-[MM]-[DD]T[HH]:[MM]:[SS]\n"
"with an optional time zone formatted as Z for GMT time or {+,-}[HH]:[MM] (with or without separating colon) for an offset\n\n"
"Should Match:\n"
"2008-09-15T15:53:00\n"
"2007-03-01T13:00:00Z\n"
"2015-10-05T21:46:54-1500\n"
"2015-10-05T21:46:54+07:00\n\n"
"Should Not Match:\n"
"2015-10-05T21:46:54-02\n"
"0\n"
"2008\n"
"2008-09\n"
"2008-09-15\n"
"2008-09-15 11:12\n"
"2008-09-15 11:12:13\n"
"1988-05-26T23:00:00.000Z")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")