package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)hello|world`)
var str = `hello
world
abc
helloworld
he
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}