use strict;
my $str = 'write(\'G\',\'(\', \'=\', \',\');';
my $regex = qr/\s+|(?=[^\w'])|(?<=\W)(?=')/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";