$re = '/\s+|(?=[^\w\'])|(?<=\W)(?=\')/';
$str = 'write(\'G\',\'(\', \'=\', \',\');';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;