import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!$|.*\\'[^\\x22]+$)(?:([0-9]+)\\')?(?:([0-9]+)\\x22?)?$";
final String string = "1'\n"
+ "1'2\"\n"
+ "1'2\n"
+ "2\"\n"
+ "2\n"
+ "1'1'\n"
+ "2\"2\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}