re = /^(?!$|.*\'[^\x22]+$)(?:([0-9]+)\')?(?:([0-9]+)\x22?)?$/m
str = '1\'
1\'2"
1\'2
2"
2
1\'1\'
2"2"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end