package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:(')([^']*)'|(")([^"]*)")\s*\|\s*l10n`)
var str = `<a href="{{'Čeština' | l10n}}" ng-click="setLocale('cs_CZ')">{{'field."text" || Čeština' | l10n}}</a>
<a href="{{"Čeština" | l10n}}" ng-click="setLocale('cs_CZ')">{{"field.'text' || Čeština" | l10n}}</a>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}