$re = '/(?:(\')([^\']*)\'|(")([^"]*)")\s*\|\s*l10n/';
$str = '<a href="{{\'Čeština\' | l10n}}" ng-click="setLocale(\'cs_CZ\')">{{\'field."text" || Čeština\' | l10n}}</a>
<a href="{{"Čeština" | l10n}}" ng-click="setLocale(\'cs_CZ\')">{{"field.\'text\' || Čeština" | l10n}}</a>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);