import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img.*?src=\"([^\"]*)\".*?width=\"([^\"]*).*?height=\"([^\"]*).*?>";
final String string = "<img src=\"http://images.efollett.com/books/978/047/012/9780470129296.gif\" width=\"80\" height=\"100\" alt=\"Organic Chemistry I (as Second Language)\" />";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}