package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^http:\/\/(www\.)*(example\.com)(.*)`)
var str = `http://example.com/
http://www.example.com/
http://testexample.com/
https://example.com/
https://www.example.com/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}