$re = '`^http:\/\/(www\.)*(example\.com)(.*)`m';
$str = 'http://example.com/
http://www.example.com/
http://testexample.com/
https://example.com/
https://www.example.com/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);