package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^BLTY(?::\w+){3}(?:\.\w+){3}/.*\(\d+\)$`)
var str = `BLTY:ENCQ0000:SERVER:TEMP.PPMQ8FE.Y.323/TCP/gtg23.dev.pmt.com(3213)
#BLTY:ENCQ0000:SERVER:TEMP.PPMQ8FE.Y.323/TCP/gtg23.dev.pmt.com(3213)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}