re = /^BLTY(?::\w+){3}(?:\.\w+){3}\/.*\(\d+\)$/m
str = 'BLTY:ENCQ0000:SERVER:TEMP.PPMQ8FE.Y.323/TCP/gtg23.dev.pmt.com(3213)
#BLTY:ENCQ0000:SERVER:TEMP.PPMQ8FE.Y.323/TCP/gtg23.dev.pmt.com(3213)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end