#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\(?868\)?(\s*|-)\d{3}(\s|-)\d{4}|868\d{7})$"
Local $sString = "8680000000" & @CRLF & _
"(868) 000 0000" & @CRLF & _
"868-000-0000" & @CRLF & _
"868 000-0000" & @CRLF & _
"" & @CRLF & _
"8880000000" & @CRLF & _
"767-000-0000" & @CRLF & _
"868-0000000" & @CRLF & _
"(868)0000000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")