$re = '/^(\(?868\)?(\s*|-)\d{3}(\s|-)\d{4}|868\d{7})$/m';
$str = '8680000000
(868) 000 0000
868-000-0000
868 000-0000
8880000000
767-000-0000
868-0000000
(868)0000000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);