$re = '/\s*(?:"([^"]*)"|([^,]+))\s*,?/';
$str = '"C:\\name, name, name\\",222,45,8,18,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);