re = /\s*(?:"([^"]*)"|([^,]+))\s*,?/
str = '"C:\\name, name, name\\",222,45,8,18,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end