#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*--)[\w-]+$"
Local $sString = "apple123" & @CRLF & _
"-apple-123" & @CRLF & _
"app-le123" & @CRLF & _
"a-p-p-l-e-1-2-3" & @CRLF & _
"" & @CRLF & _
"--apple123" & @CRLF & _
"app--le123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")