$re = '/^(?!.*--)[\w-]+$/m';
$str = 'apple123
-apple-123
app-le123
a-p-p-l-e-1-2-3
--apple123
app--le123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);