const regex = /^([0-9a-zA-Z])(?!.*\1$)[0-9a-zA-Z]{5,}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([0-9a-zA-Z])(?!.*\\1$)[0-9a-zA-Z]{5,}$', 'gm')
const str = `abcdef
abcdea`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}