import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "return[ \\t]+[^\"\\n;]*;";
final String string = "//please {return\n"
+ "[self funcA];}\n\n"
+ "return true;";
final String subst = "{\\g<0>}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}