const regex = new RegExp('return[ \\t]+[^"\\n;]*;', '')
const str = `//please {return
[self funcA];}
return true;`;
const subst = `{\g<0>}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);