$re = '/(?<= |^)\+(?=\w{1,3}\b)/m';
$str = '+a +string +of +words +with +different +lengths';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);