re = /(?<= |^)\+(?=\w{1,3}\b)/m
str = '+a +string +of +words +with +different +lengths'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end