use strict;
my $str = 'Ipod & Itunes For Dummies (Isbn - 0470174749)
Baby Massage For Dummies (Isbn - 0764578413)
';
my $regex = qr/(.*) \(Isbn.*\)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";