$re = '/(.*) \(Isbn.*\)/m';
$str = 'Ipod & Itunes For Dummies (Isbn - 0470174749)
Baby Massage For Dummies (Isbn - 0764578413)
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;