const regex = /^[1-9][0-9]*$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[1-9][0-9]*$', 'mg')
const str = `0.0
0
1.2
0.1
0.23
.2345
2.3
1
111
2
5
9
10
15
50
1000
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}