re = /^[1-9][0-9]*$/m
str = '0.0
0
1.2
0.1
0.23
.2345
2.3
1
111
2
5
9
10
15
50
1000
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end