#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?:("?(?:.*)"?)\s*)?\s<(.*@.*)>|(?:mailto:(.*@.*))|(.*@.*)"
Local $sString = "John Smith <john.smith@gmail.com>" & @CRLF & _
"John Smith <johnsmith@gmail.com>" & @CRLF & _
""John Smith" <johnsmith@gmail.com>" & @CRLF & _
""John" <johnsmith@gmail.com>" & @CRLF & _
"John Smith<johnsmith@gmail.com>" & @CRLF & _
"<johnsmith@gmail.com>" & @CRLF & _
"johnsmith@gmail.com" & @CRLF & _
"mailto:johnsmith@gmail.com" & @CRLF & _
""John"<johnsmith@gmail.com>" & @CRLF & _
"" & @CRLF & _
"To: John Smith <john.smith@gmail.com>" & @CRLF & _
"From: John Smith <john.smith@gmail.com>" & @CRLF & _
"Reply-to: john.smith@gmail.com" & @CRLF & _
"Return-path: <john.smith@gmail.com>" & @CRLF & _
"Message-id: <john.smith@gmail.com>" & @CRLF & _
"References: <john.smith@gmail.com>" & @CRLF & _
"Original-recipient: rfc822;john.smith@gmail.com" & @CRLF & _
"for john.smith@gmail.com" & @CRLF & _
"ESMTPSA id <john.smith@gmail.com>" & @CRLF & _
"domain of john.smith@gmail.com" & @CRLF & _
"envelope-from=john.smith@gmail.com" & @CRLF & _
"(ORCPT john.smith@gmail.com)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")