import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(\"?(?:.*)\"?)\\s*)?\\s<(.*@.*)>|(?:mailto:(.*@.*))|(.*@.*)";
final String string = "John Smith <john.smith@gmail.com>\n"
+ "John Smith <johnsmith@gmail.com>\n"
+ "\"John Smith\" <johnsmith@gmail.com>\n"
+ "\"John\" <johnsmith@gmail.com>\n"
+ "John Smith<johnsmith@gmail.com>\n"
+ "<johnsmith@gmail.com>\n"
+ "johnsmith@gmail.com\n"
+ "mailto:johnsmith@gmail.com\n"
+ "\"John\"<johnsmith@gmail.com>\n\n"
+ "To: John Smith <john.smith@gmail.com>\n"
+ "From: John Smith <john.smith@gmail.com>\n"
+ "Reply-to: john.smith@gmail.com\n"
+ "Return-path: <john.smith@gmail.com>\n"
+ "Message-id: <john.smith@gmail.com>\n"
+ "References: <john.smith@gmail.com>\n"
+ "Original-recipient: rfc822;john.smith@gmail.com\n"
+ "for john.smith@gmail.com\n"
+ "ESMTPSA id <john.smith@gmail.com>\n"
+ "domain of john.smith@gmail.com\n"
+ "envelope-from=john.smith@gmail.com\n"
+ "(ORCPT john.smith@gmail.com)";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}